Funcion si en Excel, Usando condicionales o pruebas logicas

Muchas personas que trabajan con Excel desean mejorar sus habilidades con la hoja de cálculo y aprender a utilizar ésta herramienta de una manera avanzada. Si usted es una de estas personas entonces debe saber que la funcion Si en Excel le hará cruzar la línea de usuario normal a usuario avanzado. Sí, efectivamente aprender a usar ésta función lógica le permitirá optimizar y agilizar el trabajo con la herramienta de Microsoft Excel.

La funcion Si en Excel (ó fórmula si excel) es una función integrada de Microsoft Excel (parte de la familia de funciones lógicas de Excel) que permite evaluar una condición (una prueba logica de Excel) y devolver un resultado, dependiendo si la condición es verdadera o falsa.

En ésta oportunidad vamos a explicar cómo se usa ésta funcion (como se escribe en la hoja de Excel) de una manera básica. Además se pretende indicar como usar la funcion si en Excel en conjunto con otras funciones y fórmulas (en otro tutorial abordaremos el tema de funcion si anidada). En los siguientes ejemplos se presenta la función si para el trabajo con números, celdas con texto, celdas con fechas, celdas en blanco.

Alguien puede preguntarse: la función si de Excel cambia según la versión de Excel,  es la misma en Excel 2010, Excel 2013 o Excel 2016?. La respuesta es No. La función Si tiene la misma sintaxis, utilidad o aplicación en todas la versiones de Excel.

Para qué sirve la funcion SI en Excel

Básicamente su uso permite devolver valores de celdas sobre los que aplicamos una prueba lógica o varias pruebas logicas. Observemos cómo funciona esto con el siguiente ejemplo: en la imagen tenemos 3 columnas, vendedor, ventas y comisión. La columna de comisión la obtendrán los vendedores con ventas superiores a 1200. Para saber cuáles son las celdas de los vendedores que obtendrán una comisión requerimos la funcion si.

para que sirve la funcion si en excel
para que sirve la funcion si en excel

Según lo anterior alguien puede considerar que solo debe aplicar un filtro. Es totalmente válida ésta afirmación, sin embargo el objetivo de la funcion Si es devolver un valor para poder hacer algo con este valor. Continuando con el ejemplo no basta únicamente con obtener el valor de la venta de los vendedores que obtendrán una comisión, también debemos calcularla (para este fin se debería aplicar un formula en la columna D o E con el valor obtenido).  Además hay que tener en cuenta que si intenta aplicar un filtro a un rango de miles de valores esto le puede tomar demasiado tiempo.

Cómo se escribe la funcion SI en Excel – Sintaxis

Como se observa en la imagen la función si necesita tres argumentos, separados por punto y coma (o coma según su instalación y/o configuración de Microsoft Excel). La sintaxis es:

=SI ( PRUEBA LOGICA ; VALOR SI VERDADERO; VALOR SI FALSO )

Analice la estructura de la función Si en Excel a través de la siguiente imagen.

funcion si en excel - como se escribe - sintaxis
funcion si en excel – como se escribe – sintaxis

Tenga en cuenta que la parte superior de la imagen es una ilustración didáctica, la funcion Si está escrita correctamente en la celda D20. Es importante saber que la forma de expresar la condición lógica depende únicamente de su necesidad en el contexto de la información que está trabajando. Puede intentar manejar la condición lógica como mejor le parezca y  entienda adaptando los operadores lógicos a su necesidad específica.

Prueba lógica: Es un valor o una expresión lógica que puede ser VERDADERO o FALSO. Es una expresión requerida por la función, es decir la función No trabajará sino se escribe este argumento. En este argumento, se puede especificar un valor de texto, fecha, número, generalmente una prueba lógica utiliza un operador de comparación (ver más adelante operadores de comparación). Por ejemplo, una prueba lógica puede expresarse como:

  • B1 = “vendido” (Quiere decir: si el texto contenido en B1 es igual a “vendido”).
  • B1 < 01/12/2014 (Quiere decir: si la fecha contenida en B1 es inferior a 01/12/2014).
  • B1 = 10 (Quiere decir: Si el número contenido en B1 es igual a 10).
  • B1 > 10 (Quiere decir: Si el número contenido en B1 es mayor a 10).

En el ejemplo de la imagen la prueba lógica evalúa si el valor de C16 es mayor a 5.

Valor si Verdadero: El valor a devolver cuando la prueba lógica se evalúa como VERDADERO, es decir, si se cumple la condición. Este argumento es opcional, se puede o no especificar dentro de la función. En el ejemplo la imagen el resultado de la prueba lógica es VERDADERO por lo que el resultado en la celda D20 es C16 + 2 = 10.

Valor si Falso: Es el valor que se devuelve si la prueba lógica se evalúa como FALSO, es decir, si no se cumple la condición. Este argumento es opcional, se puede o no especificar dentro de la función

Operadores de Comparación de la funcion Si en Excel

  • Mayor que: >
  • Menor que: <
  • Igual que: =
  • Diferente de: <>
  • Mayor o igual que: >=
  • Menor o igual que: <=

Aunque los dos últimos parámetros de la función si son opcionales, debe tener especial cuidado al omitir argumentos de la función para evitar resultados inesperados.

Valor Si verdadero omitido

Si se omite el argumento valor si verdadero en su fórmula SI de Excel (es decir, solo escribe las comas que separan el argumento), la función SI devuelve un cero (0) cuando se cumple la condición. Éste es un ejemplo de dicha fórmula: = SI (C2=10 ,, “MENSAJE”)

funcion si en excel - valor si verdadero omitido
funcion si en excel – valor si verdadero omitido

Si no desea que su fórmula Si muestre un valor cuando se cumple la condición, introduzca comillas dobles ( “”)  como segundo parámetro, de la siguiente manera: =SI(C2=10; “”; “MENSAJE”). En éste caso, la fórmula devuelve una cadena de texto vacía, no puede ser observada por el el usuario, sin embargo otras funciones de Excel si pueden saber el tipo de dato(texto) de la celda.

En la siguiente imagen se muestra un ejemplo para cada situación mencionada en el anterior párrafo, puede que sea más viable el uso de la segunda opción:

funcion si en excel - valor si verdadero omitido comillas
funcion si en excel – valor si verdadero omitido comillas

funcion si en excel – valor si verdadero omitido

Valor Si falso omitido

Sino es importante lo que sucede cuando no se cumple una condición especificada, se puede omitir el tercer parámetro en sus fórmulas SI en  Excel.

Si la prueba lógica se evalúa como FALSO y se omite el tercer parámetro (solo escribe el paréntesis de cierre después del valor si verdadero), la función SI devuelve el valor lógico FALSO. Es algo que poco predecible, sin embargo la intención es mostrarle todos los escenarios resultantes cada vez que se altera la escritura “normal” de la función. El siguiente ejemplo contempla tal situación: =SI(C2=10, “ACCION”)

funcion si en excel - valor si falso omitido
funcion si en excel – valor si falso omitido

Si coloca una coma después del argumento valor si verdadero, su función si mostrará cero (0), lo cual carece de sentido: =SI(C2=10, “ACCION”,)

funcion si en excel - valor si falso omitido cero
funcion si en excel – valor si falso omitido cero

Y de nuevo, el enfoque más razonable parece ser especificar comillas dobles (“”) en el tercer argumento, en este caso, tendrá celdas vacías cuando no se cumple la condición: =SI(C2=10; “ACCION”; “”).

funcion si en excel - valor si falso omitido comillas
funcion si en excel – valor si falso omitido comillas

Hacer que la función SI muestre valores lógicos VERDADERO o FALSO de manera explícita

Si desea que su fórmula SI de Excel para muestre valores lógicos VERDADERO o FALSO cuando se cumple o no se cumple el condicional, respectivamente, solo debe escribir VERDADERO en el argumento valor si verdadero. Y FALSO en el parámetro valor si falso (también puede omitirse y obtendrá el mismo resultado). Un ejemplo de la fórmula:

=SI(C2=10; VERDADERO; FALSO)
o
=SI(C2=10; VERDADERO)

Nota: No es igual =SI(C2=10; VERDADERO, FALSO) que =SI(C2=10; “VERDADERO”, “FALSO”). En el primero caso sin comillas tenemos valores lógicos como argumentos en el segundo caso cadenas de texto.

Crear una funcion SI para realizar una operación matemática

En lugar de devolver ciertos valores, puede hacer que su fórmula SI pueda probar la condición lógica y  lleve a cabo una operación matemática y devuelva un valor calculado como resultado (como se vio en la segunda imagen).Esto se hace mediante el uso de operadores aritméticos u otras funciones de Excel.  La operaciones matemáticas se llevan a cabo en los argumentos valor si verdadero y / o  valor si falso. Observe un par de ejemplos de las fórmulas Si en ésta situación:

Ejemplo 1: =SI(A1>B1; C2*5; C2*6)

En la anterior fórmula se comparan los valores de las celdas A1 y B1,  si A1 es mayor que B1 entonces se multiplicará el valor en la celda C2 por 5 en caso contrario la multiplicación será por 6.

funcion si en excel - con operaciones matematicas
funcion si en excel – con operaciones matematicas

Ejemplo 2: =SI(A1<>B1; SUMA(A1:D1); “”)

En éste segundo ejemplo la fórmula compara los valores de las celdas A1 y B1,  Si el valor de A1 no es igual al valor de B1, la fórmula devuelve la suma de los valores en el rango de celdas desde  A1 hasta  D1, si la condición lógica por el contrario devuelve falso(A1 Y B1 iguales ) la celda tomará el valor de una cadena de texto vacía e invisible.

Funcion SI en Excel para valores de texto

Habitualmente se escribe una fórmula SI para valores de texto utilizando los operadores igual (=) o no es igual a (<>), como se puede evidenciar en los siguientes ejemplos.

=SI(C2=”Bebida”; “Producto”;”Servicio”)

funcion si en excel - con cadenas de texto
funcion si en excel – con cadenas de texto

El anterior ejemplo evalúa si en la celda C2 aparece un texto igual a “bebida”, de ser verdadero muestra como resultado la cadena de texto “producto” de lo contrario se mostrará el texto “servicio”.

=SI(C2<>”Blanco”;”Sucio”;”Limpio”)

Este ejemplo prueba si en la celda C2 aparece un texto diferente de “blanco”, de ser verdadero muestra como resultado la cadena de texto “Sucio” de lo contrario se  mostrará el texto “Limpio”.

Usando La fórmula SI de Excel en el trabajo con fechas

Normalmente una prueba lógica en el trabajo con fechas puede expresarse así: =Si(C2<C3;”Hecho”;”Pendiente”), considerando que C2 y C3 son celdas que contienen fechas (ver imagen). Sin embargo no siempre toda lo que muestra una celda es lo que parece ser, algunas celdas aparentan contener una fecha, pero necesariamente no son fechas. Es por esto que se debe prestar especial atención a los resultados obtenidos al trabajar la función Si con valores de fechas.

A diferencia de muchas otras funciones de Excel, Si no puede reconocer las fechas(contenidas entre comillas) puesto que las interpreta como simples cadenas de texto, por lo que no puede expresar su prueba lógica simplemente como> “19/11/2014” o> 19/11/2014. Por desgracia estos argumentos no son válidos incluso si están contenidos dentro de una celda.

Para hacer que la función Si en Excel pueda reconocer una fecha en una prueba lógica, hay que envolverlo en la función FECHANUMERO, de la siguiente forma: FECHANUMERO( “10/06/2015”). La fórmula Si completa puede escribirse de la siguiente forma:

=SI(C1<FECHANUMERO(C2); “Hecho”; “Pendiente”)

=SI(C1<FECHANUMERO(“10/06/2015”); “Hecho”; “Pendiente”)

Como se ilustra en la siguiente imagen, esta fórmula SI evalúa las fechas de la columna C y devuelve “Hecho” de lo contrario, la fórmula devuelve “Pendiente”.

funcion si en excel - con fechas
funcion si en excel – con fechas

Funcion Si para celdas en blanco

Es posible que en ocasiones se necesite validar si una celda se encuentra vacía o no, para esto tenga en cuenta:

  • Utilice la función de Excel SI conjuntamente con ESBLANCO, o
  • Utilice las expresiones lógicas “=” (igual a blanco) o <> “” (diferente de blanco).>

Un ejemplo de esto puede escribirse de la siguiente manera:

= SI (A1 <> “”; A1/2 ; 0)

=SI (ESBLANCO(A1); A1/2 : 0)

Para evitar obtener resultados no deseados considere la diferencia entre las dos expresiones anteriores:

= SI (A1 <> “”; A1/2 ; 0) En este caso la celda A1 puede no contener ningún caracter visible y al evaluar la función el resultado será VERDADERO, es decir la celda puede NO estar vacía pero por el hecho de no tener caracteres visibles se considera vacía para la función.

Por el contrario en la expresión =SI (ESBLANCO(A1); A1/2 : 0) el resultado sera VERDADERO siempre y cuando la celda se encuentre absolutamente vacía. No puede existir ningún caracter visible o invisible. Se recomienda en lo posible el uso de esta opción  o realizar la validación con las dos opciones de manera conjunta para tener mayor control sobre los resultados.

En el siguiente ejemplo la celda A1 incluye los caracteres (=””) visibles en la barra de fórmulas pero invisibles en la celda, sin embargo la siguiente Fórmula SI en conjunto con ESBLANCO es capaz de detectar que la celda no esta totalmente vacía por lo que el resultado evidencia que evalúa la condición lógica como falso.

Esta es la fórmula SI escrita en la celda B1: =SI(ESBLANCO(A1);”ACCION”;”ALERTA”)

funcion si en excel - en concunto con esblanco
funcion si en excel – en concunto con esblanco

En comosehace.in esperamos que esta información sea de su mayor utilidad. Le invitamos al mismo tiempo que comparta esta publicación y revise los siguientes enlaces: Curso basico de Excel gratis y Como buscar datos en excel desde una columna

Referencias:

https://www.ablebits.com/office-addins-blog/2014/11/26/if-function-excel/

Add a Comment

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *